Blocked Website Content

Hi I am running Jellyfin on my filme.serverwolf.de domain.
Last night I tried adding some Buttons to the Interface and it worked great, but at some point I replaced a file in the web Folder and now everything is broken.
(Only login screen works, but that's NOT false code! I put back the old file)

To understand what I did:

  1. I used Samba to connect from my PC to the server with the following permissions:
    [(Censored)]
    path = /
    public = yes
    writeable = yes
    ; browseable = yes
    valid users = (Censored)
    force user = root
    force group = root
    create mask = 0770
    directory mask = 0771
    force create mode = 0660
    force directory mode = 0770

  2. Then I edited a file locally and replaced the one in my website.

I changed the file permissions already because it wasn't the same as the other files.

Before I also failed to add my own logo and thought it might be the image type but now I realized any new file gets rejected. Thats why I guess it might be https related BUT when I connect via http I also have the same issue what keeps me guessing wrong I think.
The server is running behind a reverse Proxy and I certified it with certbot --apache.


(LibraryMenu.js is the file I replaced)
PS: By the way, this is not a specific problem for this website. My other website running on this server has the same problem. Couldn't make the background show up... When I replaced the index.html file the page was not visible at all anymore and it is still not showing. Don't really know what to do but something about my configuration seems off.

I am pretty new and have no experience with webhosting, so please excuse me for my basic level of understanding :slight_smile:
Thanks in advance for you help,
Simon Wolf

1 Like

Hi @sim0nw0lf

that's not a Letsencrypt relevant question.

There

is a page from your hoster, no content defined:

Not found

We could not find the site "film.serverwolf.de" on our servers.

So ask your hoster or use your backup to restore your old configuration.

PS: Why do you have the idea doing such a thing:

If your website is managed via your hoster, that may break your configuration.

One syntax error -> the result is expected. And that's without a backup.

1 Like

Oh, sorry I misspelled! http://filme.serverwolf.de/ is the right domain.

1 Like

Certificate is ok, page works -> no problem.

1 Like

Yes, the login screen works.
I make a guest Account for you so you can see the issue!

1 Like

User: letsencryptguest
Password: letsencryptpassword

1 Like

If you need any information, I am more then happy to deliver what you need.
I just don't know what to look for...

1 Like

I'm getting a blank page, but fully secured.

The error in the browse console says your webserver returned a 404 when requesting a websocket. I'm not sure how this 404 error is related to Let's Encrypt? Sounds more like a webserver configuration error.

You said it broke when you added some buttons. Did you also change something to your Let's Encrypt certificate/TLS configuration?

1 Like

You are right! By now I also think that the certificate works as expected.
I didn't change anything other than replacing/adding a file in the web root and the replaced file acts like it doesn't exist while new files are not recognized aswell.
I thought maybe my Proxy is not setup properly?

root@filme-server:/etc/apache2/sites-available# cat jellyfin.conf
<IfModule mod_ssl.c>
 <VirtualHost *:443>
    ServerName filme.serverwolf.de
    ProxyPreserveHost On
    DocumentRoot /var/www/html
    ProxyPass /.well-known !
    ProxyPass / http://192.168.178.94:8096/
    ProxyPassReverse / http://192.168.178.94:8096/
    Include /etc/letsencrypt/options-ssl-apache.conf
    SSLCertificateFile /etc/letsencrypt/live/filme.serverwolf.de/fullchain.pem
    SSLCertificateKeyFile /etc/letsencrypt/live/filme.serverwolf.de/privkey.pem
  </VirtualHost>
</IfModule>
<VirtualHost *:80>
    ServerName filme.serverwolf.de
    DocumentRoot /var/www/html
    Redirect permanent / https://filme.serverwolf.de/
RewriteEngine on
RewriteCond %{SERVER_NAME} =filme.serverwolf.de
RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]
</VirtualHost>

and

root@filme-server:/etc/apache2/sites-available# cat jellyfin-le-ssl.conf
<IfModule mod_ssl.c>
<VirtualHost *:443>
ServerName filme.serverwolf.de
ProxyPreserveHost On
DocumentRoot /var/www/html
ProxyPass /.well-known !
ProxyPass / http://192.168.178.94:8096/
ProxyPassReverse / http://192.168.178.94:8096/
RewriteEngine on
# Some rewrite rules in this file were disabled on your HTTPS site,
# because they have the potential to create redirection loops.

# RewriteCond %{SERVER_NAME} =filme.serverwolf.de
# RewriteRule ^ https://%{SERVER_NAME}%{REQUEST_URI} [END,NE,R=permanent]

SSLCertificateFile /etc/letsencrypt/live/filme.serverwolf.de/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/filme.serverwolf.de/privkey.pem
Include /etc/letsencrypt/options-ssl-apache.conf
</VirtualHost>
</IfModule>

They were created from certbot out of the previous :80 redirect.
But I didn't specify any Document Root. This Document root is not the same as the jellyfin web root but I thought that wouldn't matter.

Is it possible that the proxy is the reason new files on the webserver are not recognized?
Or do you know where I could ask/get help to solve this issue if it is not related to letsencypt?

1 Like

managed to fix it :+1:
Realized my config worked correct and I could just reinstall the jellyfin-web package with apt