Attribute Error when setting up cerbot for WordPress website being hosted free on Google Cloud Platform

@linkp Thank you! I guess what is my next step from here? I'm not very code savvy and I'd like to get everything running as soon as I can so I can start building my website.

Any suggestions?

1 Like

It looks like you have to open port 443. Is there something in Google Cloud where you have to do that?

Also, what does this show

sudo apache2ctl -t -D DUMP_VHOSTS
3 Likes

@MikeMcQ I'm not sure, but I'll see if I can find something.

This is what that command shows:

domg_consulta@consulta-website-new-final:~$ sudo apache2ctl -t -D DUMP_VHOSTS

VirtualHost configuration:
*:80 consulta-website-new-final.us-west1-b.c.consulta-website-new-final.internal (/etc/apache2/sites-enabled/000-default.conf:1)

I notice that you attempted to revoke a certificate immediately after the rate limit. Certificate revocation has no effect on rate limits. The only thing that does is waiting them out. You typically would only need to revoke a certificate of you lost control of its secret key.

Im going step back for a bit while you review your Apache config with @MikeMcQ, but I'll still be following along.

3 Likes

I'll be stepping away for a bit so go ahead and work on it :slight_smile:

2 Likes

The output from apache2ctl -t -D DUMP_VHOSTS suggests bigger problems than I can address at the moment, as, I too, have other activities that demand my time presently.

Two things that concern me from the aforementioned output:

  1. There is no SSL vhost configured on port 443
  2. The vhost does not have a valid FQDN
3 Likes

I understand, I appreciate both of your guys' time. It might just be that I need to scrap everything and start over from scratch.

1 Like

I wouldnt, as it will likely only serve to set you back, but that is ultimately your call. There are others here in the Community who may be able to assist you further.

4 Likes

@linkp @MikeMcQ I figured it out!!! I had left the "Allow Load Balancer Health Checks" unchecked. #facepalm

3 Likes