Assessment failed: Unable to connect to the server

You need both 80 and 443

re-added port 80 & 443. thank you again for your help.

still not working out side my network.
I have the domain pointing to my external ip address
Is there anything else I should have configured?

Is 82.7.10.112 still your ip?

yes that’s correct 82.7.10.112

Hi 9peppe,
Do you have any more suggestions ?
Could really do with help.
Regards
Gordon128

Sorry, none. You might want to check again if your IP has changed.

Or check if there’s any other firewall between the outside world and the device.

Thanks anyway 9peppe, IP not changed. Gordon128

Hi @gordon128

there are some checks of your domain - https://check-your-website.server-daten.de/?q=gordonsweb.uk

Only timeouts.

You have a certificate:

Issuer not before not after Domain names LE-Duplicate next LE
Let’s Encrypt Authority X3 2020-04-01 2020-06-30 gordonsweb.uk - 1 entries duplicate nr. 1

So it’s a firewall or a wrong router configuration you have to find and to fix.

Host T IP-Address is auth. ∑ Queries ∑ Timeout
gordonsweb.uk A 82.7.10.112 Brighton/England/United Kingdom (GB) - Virgin Media Limited Hostname: cpc146294-brig23-2-0-cust623.3-3.cable.virginm.net yes 1 0
AAAA yes
www.gordonsweb.uk A 82.7.10.112 Brighton/England/United Kingdom (GB) - Virgin Media Limited Hostname: cpc146294-brig23-2-0-cust623.3-3.cable.virginm.net yes 1 0
AAAA yes

Looks like a home server.

Osiris, Thank you. The only firewall between server and out side is in the router.
If I key in the domain name on any computer or mobile device wired or WiFi, it works fine.
It just doesn’t work from out side the network.

JuergenAuer, Yes it is a home server. I have configured port forwarding for ports 80 & 443 to the internal server IP address. I can’t see any thing in the routers firewall config. So now running out of Ideas.
Gordon128

You are doing something wrong.

Nginx? Apache?

nginx -T

or

apachectl -S

Or you have additional firewalls. Linux over Windows? Then you have to check the Linux- and the Windows-Firewall.

apache version 2.4.38
apachectl -S results in the following:
AH00526: Syntax error on line 33 of /etc/apache2/sites-enabled/000-default-le-ssl.conf:
SSLCertificateFile: file ‘/etc/letsencrypt/live/gordonsweb.uk/fullchain.pem’ does not exist or is empty
Action ‘-S’ failed.
The Apache error log may have more information.

Server also connect direct to the router by Ethernet cable.

Use sudo or root …

sudo apachectl -S
AH00558: apache2: Could not reliably determine the server’s fully qualified domain name, using 127.0.1.1. Set the ‘ServerName’ directive globally to suppress this message
VirtualHost configuration:
*:443 gordonsweb.uk (/etc/apache2/sites-enabled/000-default-le-ssl.conf:2)
*:80 127.0.1.1 (/etc/apache2/sites-enabled/000-default.conf:1)
ServerRoot: “/etc/apache2”
Main DocumentRoot: “/var/www/html”
Main ErrorLog: “/var/log/apache2/error.log”
Mutex ssl-stapling: using_defaults
Mutex ssl-cache: using_defaults
Mutex default: dir="/var/run/apache2/" mechanism=default
Mutex mpm-accept: using_defaults
Mutex watchdog-callback: using_defaults
Mutex rewrite-map: using_defaults
Mutex ssl-stapling-refresh: using_defaults
PidFile: “/var/run/apache2/apache2.pid”
Define: DUMP_VHOSTS
Define: DUMP_RUN_CFG
User: name=“www-data” id=33
Group: name=“www-data” id=33

There is no port 80 vHost with gordonsweb.uk.

And (good) there is *:80 defined, not a single ip address.

So

curl https://gordonsweb.uk/

should work from that machine. If yes, it’s a router- or firewall problem.

curl https://gordonsweb.uk/

curl: (6) Could not resolve host: gordonsweb.uk

Hi asghar,
Server not down. Just not accessible from internet.
problem with configuration
Cheers