Are .be domains no longer resolving for LetsEncrypt?

My domain:

is registered at:

I ran a manual verify, and got invalid:

“DNS problem: NXDOMAIN looking up A for - check that a DNS record exists for this domain”

However, not only is the domain current, registered and valid, it has an A record, which I can see on DNS check sites like:

In addition, the domain resolves and can be visited. Further, the domain has successfully been validated using the exact same commands with LetsEncrypt before. And, I was able to validate 29 other domains while working on this one - only this one fails. I’ve tried several times over the course of 2 days and cannot get it to validate.

Web server:
Windows Server 2016 Datacenter x64 on AWS

Yes I’m an Administrator on the machine

(Emphasis mine) The error suggests that youʼre trying to get certified, and that domain sure doesnʼt exist.

Incorrect Nekit - it most certainly does exist. Here’s one of the LetsEncrypt files deposited on the domain in my numerous attempts to certify it. And as I said before, it has successfully been certified with LetsEncrypt before. So something appears to have changed at LetsEncrypt:

Ah, so itʼs with a `c`. Youʼve got a typo.

1 Like

Good catch! This one also came up invalid though when I was doing this with an automated script, where it was spelled correctly. But, it just worked after fixing the typo when registering it manually. Maybe it was just letsencrypt flaking out at the moment?

Either way thanks for the help!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.