Apt-get install python-certbot-apache completes defectively; no 000-default-le-ssl.conf


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is:
biokeyeng.com

Problem is now solved. The first removing python-certbot-apache and reinstalling, the problem persisted. The second time, reinstallation worked like a charm. FYI, this second installation that worked did not create a file named 000-default-le-ssl.conf, and did not require editing. What follows is the original report, that is no longer relevant.

I ran this command:

1)  apt-get install python-certbot-apache
2)  certbot --apache

on two different machines, one for a development team, and one for production. The installation for the development team’s gateway server was run first, successfully. The installation for the production gateway server completed unsuccessfully.

On the gateway server for a development team, installation worked with only the need to comment out one redundant redirect line in the file /etc/apache2/sites-available/000-default-le-ssl.conf; that development site is now completely functional.

When I ran command 1) on the production gateway server: www.biokeyeng.com, it failed to execute. I then repeated the previously executed command
0) apt-get update,
and repeated commands 1) and 2) above.

It produced this output:
Installation appeared to finish successfully; for example, instructing to backup account credentials.

My web servers are (include version):
for these test installations: Raspberry Pi version 2 (perhaps 3; both the successful install and the unsuccessful install were on identical but different machines.

The operating system my web server runs on is (include version):
Raspbian Stretch

My hosting provider, if applicable, is:
We host internally.

I can login to a root shell on my machines (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
No, we manage the sites by CLI

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot):
Both the successful install and the unsuccessful install report:
certbot 0.28.0

The file 000-default-le-ssl.conf was created only in the successful install. The defective install did not create this file.

The command:
certbot renew --dry-run
gave identical results in the successful and in the failed installation.

The development site now works as expected, but
The production website www.biokeyeng.com continues to run only the old, expired certificate.


closed #2

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.