Apache failed authorization

My domain is: jbrooksburris.com

I ran this command: sudo certbot --apache

It produced this output:

 Domain: www.jbrooksburris.com
   Type:   unauthorized
   Detail: Invalid response from http://jbrooksburris.com
   []: "<!DOCTYPE HTML PUBLIC \"-//W3C//DTD HTML 3.2
   Final//EN\">\n<html>\n <head>\n  <title>Index of /</title>\n
   </head>\n <body>\n<h1>Index of"

   To fix these errors, please make sure that your domain name was
   entered correctly and the DNS A/AAAA record(s) for that domain
   contain(s) the right IP address.

My web server is (include version): Apache/2.4.38 (Raspbian)

The operating system my web server runs on is (include version): Raspbian GNU/Linux 10 (buster)

My hosting provider, if applicable, is: Namecheap

I can login to a root shell on my machine (yes or no, or I don't know): yes

I'm using a control panel to manage my site (no, or provide the name and version of the control panel): no

The version of my client is (e.g. output of certbot --version or certbot-auto --version if you're using Certbot):

certbot 0.31.0

Additional info: I ran the domain through LetsDebug, and it checked out there. It looks like there is some misconfiguration of apache, but i cant find out what it is. I'd appreciate any help tracking this down. Thanks.

Are both these domains on the same server? Should be same IP if so. Check DNS

Name:   www.jbrooksburris.com

Name:   jbrooksburris.com

Yes they are both on the same server. I'm running a dynamic dns with namecheap.

Then you are only updating the dynamic IP for one of the names.


It looks like you are using Namecheap url redirect for the www domain.

You should instead use DNS A records to point to both your domain names (or a CNAME for the www subdomain). Use dynamic DNS if needed to keep the IP addresses in the DNS records fresh.

curl -I www.jbrooksburris.com
HTTP/1.1 302 Found
Server: nginx
Date: Fri, 10 Dec 2021 15:41:01 GMT
Connection: keep-alive
Location: http://jbrooksburris.com
X-Served-By: Namecheap URL Forward

Thank you. I'll give that a shot


It looks like that worked. Thank you for the help.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.