Another The client lacks sufficient authorization

#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: www.flash2hack.com

I ran this command:

sudo certbot --apache

It produced this output:

Saving debug log to /var/log/letsencrypt/letsencrypt.log
Plugins selected: Authenticator apache, Installer apache

Which names would you like to activate HTTPS for?


1: flash2hack.com
2: www.flash2hack.com


Select the appropriate numbers separated by commas and/or spaces, or leave input
blank to select all options shown (Enter ‘c’ to cancel):
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for flash2hack.com
http-01 challenge for www.flash2hack.com
Enabled Apache rewrite module
Waiting for verification…
Cleaning up challenges
Failed authorization procedure. www.flash2hack.com (http-01): urn:ietf:params:acme:error:unauthorized :: The client lacks sufficient authorization :: Invalid response from http://www.flash2hack.com/.well-known/acme-challenge/8MJkWM-92KNHVrujCKHNSrFC9A9LprhbH_bGfbCOkoM [50.63.202.62]: "> <body style=“padding:0; margin:0;”><meta name=“viewport” content=“widt”

IMPORTANT NOTES:

My web server is (include version):
Apache2

The operating system my web server runs on is (include version):
Ubuntu 18.10

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know):
yes
I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
no
The version of my client is (e.g. output of certbot --version or certbot-auto --version if you’re using Certbot): certbot 0.31.0

Visiting the domain redirects to the server as intended, The Router port forwards to 80 & 443 to a Fixed IP for the LAMP Stack installed in an LXC Container on Proxmox. Not sure what to do, playing around with it gets me banned from doing so after 5 attempts so I’m limited at what i can change or try.

#2

Ok so made some Additional Changes to it and getting a different Error in which I’m really confused from documentation I have been reading , My Domain Register is Godaddy, I have adjusted the DNS Manager so I have the following records
A www.flash2hack.com 192.168.1.xxx (Actual Static IP of Server)
A flash2hack.com 192.168.1.xxx (Actual Static IP of Server)

Now that Internal IP will do absolutely no good in getting to the server as its a Private IP but from documentation that’s how certbot validates its yours.

So the only way I know how to get it to the server is to forward to my public IP address, then to my router forward ports 80 & 443. I might be a step closer but the error I get now seems to not like the fact I’m forwarding to my Public IP but i may be misinterpreting this., The interesting this is when refreshing the Godaddy DNS Manager page a few times upon putting in the Port Forward it overwrites my A Record and puts in it’s own IP address, so obviously thats not going to fly…

Failed authorization procedure. flash2hack.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://public IP/.well-known/acme-challenge/LC9oBhYs4O3VPi8ZuuYHlsgRmA0GbGlT1O7mPFFQdTI: Invalid host in redirect target “public IP”. Only domain names are supported, not IP addresses, www.flash2hack.com (http-01): urn:ietf:params:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching http://public IP/.well-known/acme-challenge/Sc49PSVPKyc3hKBbcROxnUjiTVyGldzjJn7fWKR6IHM: Invalid host in redirect target “public IP”. Only domain names are supported, not IP addresses

IMPORTANT NOTES:

  • The following errors were reported by the server:

    Domain: flash2hack.com
    Type: connection
    Detail: Fetching
    http://public IP/.well-known/acme-challenge/LC9oBhYs4O3VPi8ZuuYHlsgRmA0GbGlT1O7mPFFQdTI:
    Invalid host in redirect target “public IP”. Only domain names
    are supported, not IP addresses

    Domain: www.flash2hack.com
    Type: connection
    Detail: Fetching
    http://public IP/.well-known/acme-challenge/Sc49PSVPKyc3hKBbcROxnUjiTVyGldzjJn7fWKR6IHM:
    Invalid host in redirect target “public IP”. Only domain names
    are supported, not IP addresses

    To fix these errors, please make sure that your domain name was
    entered correctly and the DNS A/AAAA record(s) for that domain
    contain(s) the right IP address. Additionally, please check that
    your computer has a publicly routable IP address and that no
    firewalls are preventing the server from communicating with the
    client. If you’re using the webroot plugin, you should also verify
    that you are serving files from the webroot path you provided.

#3

You have some kind of forwarding service enabled:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
   "http://www.w3.org/TR/html4/strict.dtd">
<html>

<head>
  <title>Forward</title>  
  <meta name="description" content="Public IP forward">
  <meta name="keywords" content="">
</head>
<frameset rows="100%,*" border="0">
  <frame src="http://67.160.142.129/.well-known/acme-challenge/8MJkWM-92KNHVrujCKHNSrFC9A9LprhbH_bGfbCOkoM" frameborder="0" />
</frameset>

</html>

I assume 67.160.142.129 is the actual IP address of your server? It’s a Comcast IP address. The forwarding service is provided by Godaddy I think.

This kind of forwarding services won’t work with Let’s Encrypt valdation through http-01 on port 80, because it doesn’t follow such framesets in HTML.

Is it possible to disable the forwarding and put your Comcast IP address directly in the DNS?

1 Like
#4

Thanks for your reply, finally got some sleep and woke up and looked at this with a fresh set of eyes, and thinking about what you said I set up 2 A type Records 1 with my Private Address and 1 with my Public address thinking well shit if its reading the records it will have to see the correct address and the public will forward it over, and sure enough it is working now!

2 Likes
closed #5

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.