Allow a port with SSL

hello i’m new to the community i install the certificate on my Apache server but i have an error on my site for a module i must allowed a port in the certificate how to add it without having this console error

my site uses a video chat with port for webcam and image when a user sends a picture or lights it webcam the certificate changes status

so my request and know how to add the port to no longer have this security problem

thank you in advance

It sounds like your application uses an alternate port for video and image transport?

Are you able to link to what application you are running, or better yet, link to the live domain?

You can definitely re-use your certificate on other ports, you just need to configure Apache/whatever the web server on the alternate port is to use the existing certificate.

The other possibility is mixed content causing the padlock to disappear, but it’s hard to tell.

1 Like

Good evening thank you for your answer

the rest of my application works well it’s just that when a member sends an image that makes the padlock disappear because it uses the port 34437 the link that is displayed when sending an image even this links he is not in https and that the domain yes I do not understand I do not know too much the system

my domain or and install the application

This appears to be a third-party service outside your control, so you would be unable to install a certificate into it. Fortunately you don’t have to, since it appears to already have HTTPS support.

All these URLs seem to work the same, but without the full URL to an image file it’s impossible to tell for sure.

So you should be able to change your application to generate links using without the port with no issue. If you do really need the port number, perhaps you can contact OVH and ask if they have an equivalent HTTPS enabled port number.

If you are not responsible for the software that generates these links, e.g. they come from some OVH code or something, you will need to contact them for assistance.

1 Like

good evening I am the owner of the application at OVH I just buy the domain

If you can change the configuration or code that generates these links to to instead start with you should try that first.

If that doesn’t work, we can try to help you get https on 34437 (or in parallel on e.g. 34438), but you would still at least need to add the s to https in all your links for that to work, so please try that first as an easier solution.

If you cannot/don’t know how to change these links, you should contact the author of the application for assistance. HTTPS is very important for communication software so I hope they would be happy to assist you with getting it working properly with their application.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.