After renew certificates, still not secured

My domain is:

I ran this command:sudo certbot renew --dry-run

It produced this output: Congratulations, all renewals succeeded. The following certs have been renewed:
/etc/letsencrypt/live/ (success)
/etc/letsencrypt/live/ (success)
/etc/letsencrypt/live/ (success)

My web server is (include version): apache

The operating system my web server runs on is (include version):apache

My hosting provider, if applicable, is: digitalocean

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m really lost on this and i’m weak on technical part. I’m managing my own website, if anyone can help and require access to ssh root, please let me know.

You only ran a "test" simulation.

i see, i removed the -dry-run and no renewal are due yet. When i visit my website, im able to see that the certificate is renew but the https status still not secured.

your site only gives a cert that only www version in SAN. did you add non www version too?

yes i did… add, or how should i check to verify your question so i can key in the code and paste the output.

you create Two certs that one has only www version, and one with only non-www version
don’t renew them, make a new cert that with both name, and delete old certs that has only one name.
certbot issue -d -d will do the job, I think

root@wallsg-1528129053139-s-1vcpu-1gb-sgp1-01:~# certbot issue -d -d


certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] …

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,

it will attempt to use a webserver both for obtaining and installing the


certbot: error: unrecognized arguments: issue

sudo certbot --apache -d -d

thank you sir, it’s fixed now. In future when it is expiring , what should i do?

Certbot will renew certs after 2 months. But I’m not sure certbot will restart Apache automatically

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.