Added a second certificate but qualsys says name mismatch

I successfully used certbot to install a certificate for

A while later I tried to install a second certificate for

It seems to have succeeded (looking at the /etc/letsencrypt and the conf files) except that qualsys reports a name mismatch on the second one (it says that the certificate name is instead of

What to do?

Hi @weinstoc,

Can you tell us what Certbot commands you ran and what output you saw?

Unless you issued the new certificate extremely recently, it doesn’t look like it actually worked. I only see two issued certificates

which are for and for, but none for This suggests that the second attempt did not actually succeed.

Also, right now is redirecting users back to, greatly decreasing the benefit of having the certificate.

I’m not at my computer, but I think I used:

./certbot-auto --apache

And then chose the domain from the list.

The cert exists in /etc/letsencrypt and I can extract the name from it and it says admin…

Also I have double checked the appropriate cons file in conf.d

The redirect in is because we are in the midst of the changeover. If you go to you will see it working.




I found (wth the help of my hosting service) a configuration error on my end. I would not have found it without your help.



This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.