Acme.sh error: authorization must be pending

@Yuri1 I’m happy that you finally were able to renew, using certbot. Potentially, the problem was in the fact that you omitted asterisk in your acme.sh-based renew command above (I doubt that it’s valid to use -d .psychiatr.ru instead of expected -d *.psychiatr.ru or '*.psychiatr.ru'; IMO, this is supported by the fact that LE recognizes the request as for multi-domain cert, but not wildcard one – see debug output). Anyway, hopefully, @Neilpang will soon clarify on this (since I quite like acme.sh - thank you for your work, @Neilpang, and would prefer to stay with it versus switching to other ACME client options).

fixed. please try again with the latest code:

acme.sh --upgrade

The reason is that you used dns manual mode first, but you didn’t pass the verification next. The previous txt value was cached by acme.sh.

I just cleared the cache if the verification is failed. So, you will get a new record next time.

4 Likes

Personally, I would suggest you not use dns manual mode.

please consider using dns api mode for dns alias mode instead.

2 Likes

done.

Thanks.:grinning:

2 Likes

@Neilpang Thank you. My pleasure. :slight_smile:

1 Like

Now it works, thank you!

1 Like