Acme challenge fails - backlash in path missing (installer script)?


#1

When I run

certbot --authenticator webroot --installer apache -w /var/www/

I get this (my domain is anonymized as xxx):

Starting new HTTPS connection (1): acme-v01.api.letsencrypt.org
Obtaining a new certificate
Performing the following challenges:
http-01 challenge for login.xxx.de
Using the webroot path /var/www for all unmatched domains.
Waiting for verification…
Cleaning up challenges
Unable to clean up challenge directory /var/www/.well-known/acme-challenge
Failed authorization procedure. login.xxx.de (http-01): urn:acme:error:connection :: The server could not connect to the client to verify the domain :: Fetching https://login.xxx.de.well-known/acme-challenge/jbIL-Dov3LBAcNyiy2VJvKCbg1YntucdVomX-34r7G0: Error getting validation data

IMPORTANT NOTES:

The installer script creates /var/www/.well-known, but in my view, the issue is that the installer script seems to put a “.” instead of a slash. It tries to access “…de.well-known/…” instead of “…de/.well-known/…”.

I run apache2 on Debian 8.1. I have not modified any apache2 config files yet.

I manually created the file “test” in .well-known and can access it online: https://login.xxx.de/.well-known/test works.


#2

First: please show the real domain name, don’t hide it.
The reason for this will most likely be a wrong redirect, try to search for .htaccess files or into your apache configuration for the following statement:

Redirect / https://your-domain

This must be completed:

Redirect / https://your-domain/

Otherwise search for RewriteRule definitions.


#3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.