Accidentally setup SSL for example.com instead of my forum URL


#1

Hi folks, web admin newbie here with a Xenforo 2.1 forum.
And I’ve made laughingly rookie mistake.

We want to switch from HTTP to HTTPS. So I was using this guide:

I was so intent on following the directions and copy/paste of the exact commands, that I totally missed needing to change the URL in this command from example.com to labusas.org:

**sudo -H ./letsencrypt-auto certonly --standalone -d example.com -d www.example.com**

Now in the Litespeed control panel, I suddenly have two VM’s. One for example.com and one for labusas.org.
And both are listeners. ugh.

What is the best way to undo this without screwing anything up?
Also, is there a good guide to free cert setup for Lightspeed?
We’re a very small non-profit type forum.

Thanks!

My domain is:
labusas.org

I ran this command:
sudo -H ./letsencrypt-auto certonly --standalone -d example.com -d www.example.com

It produced this output:

My web server is (include version):
LiteSpeed Web Server 5.3

The operating system my web server runs on is (include version):
CentOS 6

My hosting provider, if applicable, is:
Linode

I can login to a root shell on my machine (yes or no, or I don’t know):
Yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel):
LiteSpeed Web Server 5.3


#2

Hi @czeddie

the example.com is invisible. You can’t create a valide DNS entry, so no user is able to visit your forum via example.com.

And you can’t create a certificate with this name.

So it’s not really a problem.

I don’t use Litespeed. But there should be an option to remove the VM.