A problem after power outage


#1

Please fill out the fields below so we can help you better. Note: you must provide your domain name to get help. Domain names for issued certificates are all made public in Certificate Transparency logs (e.g. https://crt.sh/?q=example.com), so withholding your domain name here does not increase secrecy, but only makes it harder for us to provide help.

My domain is: nil.fi

I ran this command: rebooted servers concerned after power outage

It produced this output: e.g Chrome says Your connection is not private, … NET::ERR_CERT_COMMON_NAME_INVALID

My web server is (include version):nginx/1.12.2

The operating system my web server runs on is (include version): centos 7.5.1804

My hosting provider, if applicable, is:

I can login to a root shell on my machine (yes or no, or I don’t know): yes

I’m using a control panel to manage my site (no, or provide the name and version of the control panel): no

Strangely a few other domains on the same setup are working fine (e.g. hn-dev.eu). And to clarify, nil.fi used to work before the outage just fine


#2

The cert for nil.fi is good for 2 more months.
Please show the URL and error message you get.


#3

https://nil.fi/

The error comes from the browser, can’t upload the image here but it is a generic chrome error screen of connection not being private.


#4

You can use paste.bin or similar service.


#5

https://nil.fi/, https://apps.nil.fi/ and https://www.nil.fi/ work for me. They’re all using correct certificates.

(https://apps.nil.fi/ just returns a test web page, though.)


#6

I’d double check that you don’t have nil.fi on your computer’s (where your browser is) /etc/hosts file.

Or that you’re on a network with split-horizon DNS for that domain.

What’s IP does your computer show for:

ping nil.fi

Also, are you behind NAT? Because 212.146.21.21 appears to be residential. This could just be a lack of loopback/hairpin NAT.


#7

(For me, they all have the IPv4 address 212.146.21.21, and no IPv6.)


#8

Yep, the IP is ok.

And now it seems to workwith Vivaldi (not yesterday after the power break happened), so maybe it is just chrome cache issue after all :confused:

I’ll check it further and unless the problem shows it again I just apologize and thank you.


#9

I have it in the hosts file for the internal IP of (front) nginx server, but as I said it worked there before the outage just fine. But my Vivaldi gets it now right, so possibly it is just some Chrome cache issue


#10

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.