000-default-le-ssl.conf missing (Trying to enable HTTP/2)


#1

Hi,
I’m playing with trying to enable HTTP/2 on my website, following this website.


I have Let’s Encrypt running through ISPConfig3, I have ticked the Let’s Encrypt SSL Box to enable HTTPS. Now I am stuck on “Enable your sites”, because I don’t have /etc/apache2/sites-enabled/000-default-le-ssl.conf or any files with the ending le-ssl.conf. All I have is 000-default.conf and 000-ispconfig.conf. Can anyone help me?

Thanks


#2

I’m pretty new to this so yeah it could be a stupid mistake. I’m happy to answer/screenshot anything needed to help though


#3

Hi, I’m not familiar with ISPConfig3 but the tutorial you’re following assumes you’re using Certbot to enable HTTPS. If you used something else then yeah the files may be named differently, but you basically want to find and edit the one containing the <VirtualHost *.443> line. If there’s more than one, look for a ServerName or ServerAlias that matches your domain.

Incidentally I’m reasonably sure the line to add should be:

Protocols h2 http/1.1

(without the colon after http).


#4

Thanks for the reply,
As I said I’m pretty new - how would I find the correct file?

Thanks


#5

Maybe with grep?

grep -nHR "<VirtualHost .*:443>" /etc/apache2

Or you could use sudo apachectl -S which might be more reliable if you have a weird setup.


#6

It might also be worthwhile digging around a bit in the ISPConfig3 settings to see if there’s a checkbox or something to enable HTTP/2…


#7

So it finds a file here:
/etc/apache2/sites-available# nano default-ssl.conf
but thats under sites-available not sites-enabled so I don’t think it will work.

I have had a look around in ISPConfig3 for that setting but I don’t see it, also having googled it doesn’t look like there is an option either.


#8

Did you try the other command?


#10

Hmm, I guess tom.quickfire.digital is your domain but while you’ve indeed got a certificate for it - several actually - your server doesn’t seem to be using any of them. It’s still serving HTTP instead of HTTPS on port 443.

I guess you need help from someone more familiar with ISPConfig, sorry :frowning:


#11

Fair enough, I’ll keep tinkering away and trying it, thanks for your help though :slight_smile:


#12

Try:
grep -Eri 'servername|serveralias|virtualhost|443' /etc/apache2/sites-enabled/